ORDER of execution still not working properly on 3.12A?

Vexus related Support Questions

ORDER of execution still not working properly on 3.12A?

Postby alteredgene » Wed Apr 01, 2020 6:41 am

Hi everyone.

i wrote about this issue a while back around 3.09?

basically vexus supposed to run commands based on Y position (height).

so if 3 nodes are plugged into a single PASS node, the top most NODE will execute first.

however, that was not the case around 3.09. DEV got back to me saying it will be fixed on a release, but not sure if it is fixed or am i doing it wrong?

basically i have 2 nodes in this order

[unhide few layers]
[hide specific object]

and if i run them individually, they run as intended. but when i run the pass they both connect to, it does not run, as if the "newest" node always runs first, no matter what order i put them in.

could you let me know if this problem is fixed?
alteredgene
 
Posts: 11
Joined: Mon Apr 01, 2019 1:28 am

Re: ORDER of execution still not working properly on 3.12A?

Postby boomer » Wed Apr 01, 2020 11:54 am

This is supposed to be fixed. Can you please email your sample file to "support@boomerlabs.com" for review?

Thanks,
Mathew Kaustinen
Boomer Labs
boomer
Site Admin
 
Posts: 255
Joined: Fri Aug 11, 2006 9:03 pm

Re: ORDER of execution still not working properly on 3.12A?

Postby alteredgene » Wed Apr 01, 2020 11:31 pm

Thank you for getting back to me.

attached is a simple MAX scene with VEX file

1. on the SCENE NODE, i have made it to HIDE all layers

2. on the left TOP node, i am unhiding the BOX layer and SPHERE layer.

3. on the left BOTTOM node, i am hiding BOX002.

so the result i want is the second box to be hidden.
if i were to run this commands separately, it works as intended, but when i execute the whole network, it does not hide the BOX002 object.

perhaps its the way i have setup, but would be awesome if you could look into this.



[attachment=1]Screenshot_6.jpg[/attachment]
Attachments
delete-vexusFix.zip
(49.18 KiB) Downloaded 112 times
Screenshot_6.jpg
Screenshot_6.jpg (218.58 KiB) Viewed 1361 times
alteredgene
 
Posts: 11
Joined: Mon Apr 01, 2019 1:28 am

Re: ORDER of execution still not working properly on 3.12A?

Postby boomer » Wed Apr 08, 2020 7:12 pm

Christian,

OK, so I found the source of the issue. The Pass Node has a check box "Unhide Current Objects", when this is enabled, all of the nodes that were selected in the chain are unhidden, hence the issue you saw.

The solution is to turn this option off and you're all set.

Thanks,
Attachments
Order_Issue.png
Order_Issue.png (58.53 KiB) Viewed 1342 times
Mathew Kaustinen
Boomer Labs
boomer
Site Admin
 
Posts: 255
Joined: Fri Aug 11, 2006 9:03 pm


Return to Vexus

Who is online

Users browsing this forum: No registered users and 2 guests

cron