Submitting to Backburner?

Vexus related Support Questions

Submitting to Backburner?

Postby Linkitch » Fri Apr 06, 2018 12:55 am

I can't seem to get it working.

In the settings I've linked the Submit-script to the vexus_submitter.ms script, which makes the submitter open up and I can select the layers and click submit.

I can get the Backburner to connect and show our render slaves, as shown in the attach picture. But when I click Submit, the listener just prints "VexusTool undefined!"
It doesn't matter if I choose All servers of select an individual one, gives the same error.

I'm using Vexus v2.2.0B
Attachments
Backburner.PNG
Backburner.PNG (33.02 KiB) Viewed 5248 times
Linkitch
 
Posts: 3
Joined: Wed Apr 04, 2018 5:06 am

Re: Submitting to Backburner?

Postby boomer » Mon Apr 16, 2018 10:38 am

Hello,

Are you a registered user or using the demo version of Vexus?

Thanks,
boomer
Site Admin
 
Posts: 237
Joined: Fri Aug 11, 2006 9:03 pm

Re: Submitting to Backburner?

Postby Linkitch » Tue Apr 17, 2018 12:22 am

I am using a registered version.
Linkitch
 
Posts: 3
Joined: Wed Apr 04, 2018 5:06 am

Re: Submitting to Backburner?

Postby Linkitch » Tue Apr 24, 2018 12:30 am

Would still love a solution to this issue.
Linkitch
 
Posts: 3
Joined: Wed Apr 04, 2018 5:06 am

Re: Submitting to Backburner?

Postby boomer » Tue Apr 24, 2018 7:50 pm

Hello,

Thanks for bringing this issue to our attention. Attached are updated scripts that should resolve the issue.

Thanks,
Attachments
mxs.zip
Updated Scripts
(18.51 KiB) Downloaded 170 times
Mathew Kaustinen
Boomer Labs
boomer
Site Admin
 
Posts: 237
Joined: Fri Aug 11, 2006 9:03 pm

Re: Submitting to Backburner?

Postby thomas » Thu May 03, 2018 1:22 am

hello mathew,

2 questions please...

i can´t submit to backburner. the first click on "submit" is without "bing" and without responce. then i only hear "bings" nearly everywhere i click (in vexus:backburner 0.0.2). ip is the ip of the backburner-manager... 2 passes, there should be no demo restriction !?
i linked the vexus_submitter.ms to the "submit script". with the other scripts of you provided in "mxs.zip" i did nothing. do i have to link or copy them to make it work?

further i can´t get it linked right to render the two passes in one shot. i tried many versions of linking in the "quick render node" and the "vraysettings override" with the tokens
i can execute every single pass and it renders quite right, but i cant execute the shot so that both passes render...

can you please look into what i did wrong?

- you provide scripts for submitting to "royalrender"?

thanks for help
i´m running vexus demo version 3.0.0 on max 2018
Attachments
BL_vexus2.rar
(48.37 KiB) Downloaded 170 times
Last edited by thomas on Thu May 03, 2018 7:51 am, edited 2 times in total.
thomas
 
Posts: 7
Joined: Thu May 03, 2018 1:16 am

Re: Submitting to Backburner?

Postby thomas » Thu May 03, 2018 7:38 am

now i have a layout that works for separate rendering of the 2 shots. anyway the backburner rendering does not submit...blings after the second click on submit

is this layout ok like this or would you give me advice for a better solution ?

in the beginning the "render" group was in the middle of the both setup lines and i searched for quite 1 hour why the vray renderelements dont render for the lower setup.

[attachment=0]layout2.jpg[/attachment]
Attachments
layout2.jpg
layout2.jpg (209.52 KiB) Viewed 5141 times
thomas
 
Posts: 7
Joined: Thu May 03, 2018 1:16 am

Re: Submitting to Backburner?

Postby thomas » Fri May 04, 2018 12:33 am

this is what comes up in maxscriptlistener after clicking "submit" .

-- MAXScript Rollout Handler Exception:
-- Unknown property: "count" in undefined
-- MAXScript callstack:
-- thread data: threadID:1920
-- ------------------------------------------------------
-- [stack level: 0]
-- In submit_jobs(); filename: C:\mxs\managers\vexus_backburner.ms; position: 4482; line: 171
-- member of: StructDef:VexusBackburner
-- Locals:
-- renderCapture: V_Ray_Adv_3_60_04:V_Ray_Adv_3_60_04
-- progress_total: undefined
-- passes: undefined
-- progress_step: undefined
-- shots: #((vexus_node name:"beauty2" id:23 enabled:true children:#((vexus_node name:"Pass1" id:11 enabled:true children:#()))), (vexus_node name:"beauty2" id:24 enabled:true children:#((vexus_node name:"Pass2" id:18 enabled:true children:#()))))
-- Externals:
-- VexusBackburner: Global:VexusBackburner : (VexusBackburner toolVersion:"0.0.2" toolName:"Vexus: Backburner" instUI:Rollout:VexusBackburnerUI bb_mananger:<MixinInterface:NetManager> bb_servers:#(<MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, ...) bb_server_groups:#())
-- owner: (VexusBackburner toolVersion:"0.0.2" toolName:"Vexus: Backburner" instUI:Rollout:VexusBackburnerUI bb_mananger:<MixinInterface:NetManager> bb_servers:#(<MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, ...) bb_server_groups:#())
-- bb_mananger: Struct member:bb_mananger : <MixinInterface:NetManager>
-- ------------------------------------------------------
-- [stack level: 1]
-- called from ui_submit.pressed(); filename: C:\mxs\managers\vexus_backburner.ms; position: 13584; line: 495
-- member of: Rollout:VexusBackburnerUI
-- Locals:
-- Externals:
-- VexusBackburner: Global:VexusBackburner : (VexusBackburner toolVersion:"0.0.2" toolName:"Vexus: Backburner" instUI:Rollout:VexusBackburnerUI bb_mananger:<MixinInterface:NetManager> bb_servers:#(<MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, <MixinInterface:NetServer>, ...) bb_server_groups:#())
-- owner: Rollout:VexusBackburnerUI
-- VexusBackburnerUI: Rollout:VexusBackburnerUI
-- ------------------------------------------------------
-- [stack level: 2]
-- called from top-level
thomas
 
Posts: 7
Joined: Thu May 03, 2018 1:16 am

Re: Submitting to Backburner?

Postby boomer » Sat May 05, 2018 3:16 pm

Thomas,

Thanks for reporting this. We've improved Backburner support. Please use these improved scripts and report back your findings.

Thanks,
Attachments
mxs.zip
(19.23 KiB) Downloaded 167 times
Mathew Kaustinen
Boomer Labs
boomer
Site Admin
 
Posts: 237
Joined: Fri Aug 11, 2006 9:03 pm

Re: Submitting to Backburner?

Postby thomas » Mon May 07, 2018 12:01 am

looks good, it works now! thanks a lot
thomas
 
Posts: 7
Joined: Thu May 03, 2018 1:16 am


Return to Vexus

Who is online

Users browsing this forum: No registered users and 1 guest

cron